分享

You are running Composer with SSL/TLS protection disabled.

发布于:2020-04-08 15:32    阅读次数:52    作者:云码素材    分类:建站教程    关键词:composer  

用composer下载phpspreadsheet时一直报You are running Composer with SSL/TLS protection disabled.的错,开始以为是镜像的问题。用以下命令更换镜像还是不行。

 composer config -g repo.packagist composer https://packagist.phpcomposer.com

更新完再次执行:

composer require phpoffice/phpspreadsheet

还是报You are running Composer with SSL/TLS protection disabled.错误,

composer config -g -- disable-tls false

禁用ssl还是不行


查找资料,发现有可能是composer版本需要升级造成的,执行

composer selfupdate

升级composer版本至最新版,再次运行phpspreadsheet的composer安装命令,下载成功,搞定。


phpspreadsheet.png

推荐源码
查看更多

免费领
签到客服赚钱 反馈 回顶部